通达信缠论MACD副图公式指标

Class:通达信公式 Time:2021-2-19 Hits:1538

通达信缠论MACD副图公式指标

公式描述: 缠论MACD

参数数量: 3

参数1: SHORT, 最小: 2, 最大: 200, 缺省: 12

参数2: LONG, 最小: 2, 最大: 200, 缺省: 26

参数3: MID, 最小: 2, 最大: 200, 缺省: 9

公式类型: 技术指标公式-其他类型

画线方法: 副图

公式版本: 0

显示小数: 缺省位数

坐标线位置: 自动

额外Y轴分界: 无


参数精灵:

请设置计算参数:

SHORT: Param#0 (2.00--200.00)

LONG: Param#1 (2.00--200.00)

MID: Param#2 (2.00--200.00)

用法注释:无

公式源码:

X_1:=SUM(CLOSE*IF(MOD(DATETODAY(DATE),7)=0,1,0),3)*IF(PERIOD=5,1,0);
X_2:=SUM(CLOSE*IF(MOD(MINUTE,5)=0,1,0),5)*IF(PERIOD=0,1,0)+SUM(CLOSE*IF(MOD(MINUTE+55,30)=0,1,0),6)*IF(PERIOD=1,1,0)+SUM(CLOSE*IF(HOUR-15=0,1,0),8)*IF(PERIOD=3,1,0)+X_1+IF(X_1=0,REF(X_1,1),0)+IF(REF(X_1,1)+X_1=0,REF(X_1,2),0)+IF(REF(X_1,2)+REF(X_1,1)+X_1=0,REF(X_1,3),0)+IF(REF(X_1,3)+REF(X_1,2)+REF(X_1,1)+X_1=0,REF(X_1,4),0)+IF(REF(X_1,4)+REF(X_1,3)+REF(X_1,2)+REF(X_1,1)+X_1=0,REF(X_1,5),0)+IF(REF(X_1,5)+REF(X_1,4)+REF(X_1,3)+REF(X_1,2)+REF(X_1,1)+X_1=0,REF(X_1,6),0);
X_3:=1+4*IF(PERIOD=0,1,0)+5*IF(PERIOD=1,1,0)+7*IF(PERIOD=3,1,0)+4*IF(PERIOD=5,1,0);
DIFF:EMA(X_2,SHORT*X_3)-EMA(X_2,LONG*X_3);
DEA:EMA(DIFF,MID*X_3);
MACD:(DIFF-DEA)*2,COLORSTICK;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORGREEN;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORMAGENTA;
DRAWICON(CROSS(DIFF,DEA),DIFF,1);
DRAWICON(CROSS(DEA,DIFF),DIFF,2);

image.png

{股票教程大全,http://gpjcdq.com,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信指标破解:普通加密破解、完全加密破解、指标导入密码破解指标公式编写,指标修改,指标DLL加密等业务,详询客服!